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Release Notes
This document provides an overview of important enhancements, changes, and fixes
in the 2018 version of the PROFITstar and PROFITability programs.

PSPA Version 2018.854
The following enhancements and resolved issues were included in the 2018.854
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Exclusion of System Indexes when Deleting Indexes for Migrations
Migrations have been updated to exclude system indexes when deleting indexes.
This exclusion allows users of SQL Server® 2022 to update their databases.

Saving Report Writer Reports with More Than Max Column Count
The reports in the Report Writer can no longer be saved with more than the
maximum allowed column count.
A warning message is shown when trying to save a report that has more than 702
columns. Previously, no warning message was shown.

Fixes
● Contractual Maturity Must Never Be Greater Than Prior Month Month-End Balance

- An overflow error was seen when attempting to delete and combine accounts in
Setup > Chart of Accounts.

● Copy Allocation Rules Does Not Remove the Rules in the Target Model When That
Option Is Selected - When working in File > Copy > Rules, one step asks which
existing rules in the target model must be kept. If none are selected, then all rules
must be deleted. This scenario has not happened since the 2017 version.

● Divide-By-Zero Error Occurs When Projected Contractual Maturity Amount Is Zero
- The calculation of the projected contractual maturity amount for a month
involves dividing by a value that represents the remaining original balance after
the prepayment is divided by the original balance. If the amount of the remaining
original balance was zero, then the result was a divide-by-zero error.

● Post-Allocated Balance Sheet YTD Income Is Being Calculated from the Base
Model Instead of Current Model - If a PA client could calculate post-allocated
balance sheet YTD Income, and they were running allocations in a what-if model,
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then the balance sheet YTD Income was being calculated from the Base model
instead of the what-if model they were in.

● Sometimes Dividends Are Not Taken Out of Projected Undivided Earnings Account
- When a specific set of steps were taken when running a User-Defined Quick
Projection, the dividends defined in the databank were not taken out of the
balance sheet Undivided Earnings account.

PSPA Version 2018.814
The following enhancements and resolved issues were included in the 2018.814
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Added % Prepay to Total Accounts
A % Prepay value was added to total accounts in both the Report Wizard >
Analytical > Prepayment Detail report and in the Maturity/Repricing edit grids when
using a Prepay view.

Fixes
● Error Received When Generating PA Income Statement Reports - Requesting a

PA-specific Income Statement report for Organization or Product data using QTD
of YTD time frames resulted in an error. This issue has been corrected.

● Economic Scenarios Import Not Handling Dates with Quotes - When importing
Economic Scenarios data using the Tools menu command, the program was not
able to handle dates inside quotes. Now it can. In addition, the parsing of dates
was enhanced to handle some other common date formats.

● Variance Reports with Invalid Columns - An error was returned if you tried to edit
or access the Variance Report Setup screen for a report with a bad column.
Now the application allows you to access the setup screen and fix the bad
column. The bad column is highlighted in red with bad column references
changed to show as Column 0. Select Edit in the red box, and then enter the
correct column information to fix the problem.

Release Notes 5 © 1999-2024 Jack Henry & Associates, Inc. ®
PROFITability®, PROFITstar® Release 2018 | April

2024



PSPA Version 2018.807
The following enhancements and resolved issues were included in the 2018.807
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Passwords - Eliminated Support for Blank Passwords
To provide additional security to the application, after a data set is upgraded to
2018.807 or later, the use of blank passwords is no longer an option.

NOTE
You are encouraged to make a full backup of your database before upgrading to
the latest version.

You can still log into the application with a blank password if that was how you were
previously set up.
After logging in, all users are asked to change their passwords. If your old password
was blank, then do not enter a value in that field. Your new password must be at
least eight characters long.
If your old password was at least eight characters long, then the new password can
be the same as the previous one.
One change to the 2018.807 or later versions is that in Setup > User > Permissions >
Security Options, the Password Minimum Length option must be enabled with a
minimum length of at least eight. The application enforces these settings.

NOTE
If a situation arises where the institution's Security Administrators cannot log in,
then ask your client services analyst to reset the password for those users if they
are currently set up in the database.

PSPA Version 2018.805
The following enhancements and resolved issues were included in the 2018.805
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Projected Rates - Import Economic Scenarios Data
The Import Economic Scenarios Data command on the Tools menu lets subscribers
to the Economic Scenarios Data service load many monthly key rates and quarterly
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macroeconomic indicators from a .csv file into the current model's projected
Databank time frames.

PSPA Version 2018.798
The following enhancements and resolved issues were included in the 2018.798
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● Projections - Strategy Monitor - On the Strategy Comparison tab, the saved

strategies that were included frequently showed the same FYE Net Income values
when the values should have been different.
This issue is corrected in the current release.

● Projections - Key Rate Ties - When a variable-rate account was using both a
Repricing Interval (a Chart of Accounts Projections tab setting) and an Initial
Interval (a Key Rate Tie setting), Projections continued using the Initial Interval
to determine the initial repricing of new volume, even after the Key Rate Tie was
unavailable.
Now, in this situation, Projections use the Repricing Interval when the Key Rate Tie
is unavailable.

● Copy Budget with Post-Allocated Values - When trying to copy a budget that
contained post-allocated values, users were erroneously seeing a message
implying that some or all the source budget's time frames had not been allocated.
If they continued with the process, only pre-allocated data was copied.
The message read: Only pre-allocated data will be copied. All time frames must
contain completed allocations for post-allocated data to be included. Do you
want to continue?
This message is no longer shown if all the source budget's time frames have been
allocated.

● Report Wizard - Use Default Format - On the Format tab of the Report Wizard,
selecting Use Default Format causes an Edit Default Format option to appear.
However, in the 2018 edition of PROFITstar and PROFITability, this option is
unavailable, making it impossible to edit the default format.
In the 2018.798 version, the Edit Default Format option is enabled so that it is
possible to change the format settings.
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PSPA Version 2018.768
The following enhancements and resolved issues were included in the 2018.768
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fix
● Report Writer - Data Item Issue - If an account's current month-end balance

was zero, then the related Contractual Maturity and Actual Maturity data items
were showing incorrect values. If the current month-end balance was a nonzero
amount, then the data items were correct. Now, the Contractual Maturity and
Actual Maturity data items are zeroed out when calculating projections for an
account with a month-end value of zero.

PSPA Version 2018.747
The following enhancements and resolved issues were included in the 2018.747
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● PROFITstar Portfolio - Two-Digit Dates Handled Incorrectly - The Portfolio Import

handled two-digit dates differently than the PROFITstar/PROFITability (PS/PA)
Download did. For example, when calculating from the current month, a Maturity
Date of 50 was interpreted as 1950 instead of 2050.
Portfolio and PS/PA now calculate two-digit dates the same way.

● PROFITstar Portfolio - Security with a Maturity Date in the Past - An exception
occurred during the Portfolio Import process if a security with a Maturity Date in
the past was imported. Now, if this situation is encountered, no error is returned.

PSPA Version 2018.731
The following enhancements and resolved issues were included in the 2018.731
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● Key Rate Shock Constraints Ignored in Custom Rate Scenarios - If a Custom rate

scenario was used in IRSA or Fair Value, and if the scenario projected a Key Rate to
go negative, then the Key Rate would do so even if its Shock Constraint was set to
Do Not Allow Negative Rates.
Now, the Shock Constraint in Databank Setup is honored.
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NOTE
This enhancement fix was introduced with the release of the redesigned IRSA and
Fair Value modules in version 2018.418. As a result, IRSA and Fair Value results
obtained since then, which used Custom rate scenarios to test negative rate
scenarios, could possibly change.

● Unable to Log in If the Database File Extension Was Missing - Some users received
an error when attempting to log into PROFITstar or PROFITability due to a missing
or incorrect database file extension.
This fix allows the program to continue logging in, even if it does not find the
expected file.

PSPA Version 2018.726
The following enhancement and resolved issues were included in the 2018.726
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Risk Analysis - Earnings at Risk Results - ALM Risk Analysis Packet (PS Only)
Following the redesign of PROFITstar's IRSA and Fair Value functionality, the scenarios
used in the Earnings at Risk section of the ALM Risk Analysis predefined report packet
were not available.
Now, the Standard Rate Shock, which you select on the General Settings tab of
Preferences Setup, determines the shocks that are used for the Standard Up and
Standard Down scenarios in the ALM Risk Analysis report packet.

NOTE
The Standard Rate Shock scenarios are always calculated when IRSA is even if
equivalent shock scenarios are not set up to show in the IRSA screen.

Fixes
● Missing Account Links Causing a Download Error - An error, which closed the

program, could sometimes occur during the download if there were invalid or
missing account links.
If this instance occurs, then an error message appears but the program is not
closed.
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PSPA Version 2018.704
The following enhancements and resolved issues were included in the 2018.704
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Chart of Accounts - After Deleting Accounts Run the Chart Error Detection Report
In certain instances, you may be allowed to delete an account, even though other
accounts could be affected. For example, when a balance sheet account is set up to
use a key rate account as the prepayment driver rate, and that key rate account is
deleted, you end up with a driver rate that has zero in all time frames.
Now, while saving out of Databank Setup or Chart of Accounts Setup, you are
encouraged to check the Chart Error Detection report to make sure that the deletion
did not cause unexpected problems.
The message reads: Accounts were deleted. Run the Chart Error Detection report to
make sure that the deleted accounts were not referenced elsewhere.

Projections - Matched Funded FTP Rate Circular References (PA Only)
A warning message has been added to alert you if circular references are detected
in the formulas used to calculate Matched Funded FTP Rates.
You see a warning when you change to the model containing the circular references.
Also, if you try to go into Projections, you get a similar message, and you are not
allowed to open the Projections module until the issue is resolved.

General - Additional Information Provided When an Error Occurs
When the An error occurred message is received, a new Show Details link now
provides some additional information related to the cause of the error.
Sometimes, the information allows you to correct the issue without needing to call in,
such as when a full hard drive causes the error.

Fixes
● Reverse Sign Setting – When the Reverse Sign Treatment setting was applied to

an account in the Download's Account Link Setup, the sign was reversed for both
the amounts and the rates. Now, this setting does not affect rates. Rates remain
the same as they are in the extract file.
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● Charts Unnecessarily Saved During the Move & Link – If PROFITstar Portfolio was
included in the download, the chart of accounts was saved during the Move & Link
process even if no changes had occurred.
Now, the program checks to see if any changes were made before it attempts to
save anything.

● Projected Offering Rate Check When Validating Projections – In the Validating
Projections step of the IRSA and the Fair Value Validation tool, the check for
Offering Rate changes greater than 25% was not calculated correctly. This issue
is now fixed.
NOTE
Whenever the prior month value for an account is zero, the check is ignored.

● Fair Value Combined (Last Calc) Report – When the Fair Value Combined (Last
Calc) report was saved as an Excel® file, values in the Average Life column were
formatted as percentages.
In this release, Average Life values, which represent numbers of years, are
correctly saved as numbers.

● User Security Settings Report – An error was returned when this report was
requested from Setup > User Permissions and the institution had duplicate
organization names.
Now, an Org. ID number from Setup > Preferences > Organization Setup is
appended to each organization name in the report, to make each unique.

PSPA Version 2018.669
The following enhancements and resolved issues were included in the 2018.669
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● PROFITstar Error Occurs When the Database Has .NDF Files - If a large database

was using .ndf files for split data storage, then an error occurred when users tried
to get into PROFITstar.
Now, all the Stored Procedures can access the information in the .ndf files.

● Download Link Exception on Zero-Balance Records with FTP Rate and ILD - When
the FTP Rate field is included in the download file layout, a link exception occurred
if a non-zero FTP Rate was included with a zero-balance record, which was also
using instrument level detail.

● Stress All Key Rate Tie Lags Option Was Incorrectly Unavailable - When all a
model's key rate ties had flat scenarios with a lag of zero, but other scenarios
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did have non-zero lags, the IRSA calculation option to Stress All Key Rate Tie Lags
was unavailable.
Now, this option is enabled if any scenario has a lag.

● Fair Value Documentation Reports Account Order - The Fair Value documentation
reports were not always showing the accounts in Chart of Accounts order.

PSPA Version 2018.650
The following enhancements and resolved issues were included in the 2018.650
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

What-If Models - Display What-If Models in Alphabetical Order
You can now list your models in alphabetical order by selecting the Show Models in
Alphabetical Order setting on the General Settings tab of Preferences Setup.

NOTE
Each time you launch the program, you are placed either in the Base Model or
the first available What-If model for which you have security access, regardless of
where that model appears in an alphabetical listing.

Fixes
● Report Writer and Projected Contractual Cash Flows - It is now possible to pull

contractual cash flow information from Projections in Report Writer.
The Contractual Maturity and Actual Maturity data items were always available to
be used in reports, but, before this release, they did not get projected data values.
NOTE
After upgrading to the latest version, remember you must balance and save
Projections before you try to pull these values from future time frames.

● IRSA Custom Scenarios - Ratios referencing Databank accounts did not calculate
correctly in IRSA Custom Scenarios.

● Exporting PA Data > FTP Rates - If a user deleted an organization and then tried
to export FTP Rates, an exception occurred. This PROFITability report is generated
from the Tools menu.

● Chart Error Detection Report - When certain newer Special Account Codes were
used, it was not possible to run the Chart Error Detection report.
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PSPA Version 2018.569
The following enhancements and resolved issues were included in the 2018.569
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● Global Insight Import - An adjustment to the PROFITstar code was required to

handle the additional rates and codes found in the new Global Insight file.
Now, if the new rates are added to your Databank table, then they correctly import.

PSPA Version 2018.567
The following enhancements and resolved issues were included in the 2018.567
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

IRSA and Fair Value - New Decay Speeds Stress Testing Options Added
In the Calculation Options for IRSA and Fair Value, a Decrease all decay speeds
choice is now available.

Fixes
● Report Central Multiple Reporting Groups - Generating Multiple Reporting Groups

from Report Central took longer in earlier versions of 2018 than it did in the 2017
editions of the software.
The previous performance has been restored.

● Var % in Variance Reports - If a budgeted value for an account was negative,
but the actual value was positive, the Var $ displayed in Variance reports was
also positive. However, the corresponding Var % showed a negative percentage
change.
Now, the signs on values in the Var $ and Var % columns agree.

● Stress Testing Options and Historical FV - Historical Fair Value should not be
affected by stressed calculations, but previous versions of 2018 saved stress
testing results to history.
Now, Fair Value results are not saved to history if Stress Testing Options are used in
a Fair Value calculation.
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● IRSA/FV Calculation Options and Total Deposits - PROFITstar returned an error
when users attempted to edit the IRSA/FV Calculation Options if their chart of
accounts was missing the Total Deposits special account code.
Since the problem affects the program's ability to determine if there are any
decay accounts when Total Deposits are missing, the Stress All Decay Speeds
section of the Stress Testing Options is dimmed as if there are no accounts with
decay.

PSPA Version 2018.506
The following enhancements and resolved issues were included in the 2018.506
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● UDQP Duplicate Key Error When New Volume is the Data Item - This enhancement

fix was like the UDQP Duplicate Key Error fixed in the prior release, except that this
error occurred when any rate-bearing Balance Sheet account had its Data Item
set to New Volume.

● Prepay Stress in the IRSA and Fair Value Calculations - In the IRSA or Fair Value
Calculation Options, you can specify how prepayment speeds are stressed.
However, after calculating IRSA or Fair Value, there was no change to the
prepayment speeds for any accounts that used instrument level detail.
Regardless of the calculation option selected, prepayment stress was ignored for
these accounts.

● Cash Flow Report and Print Levels - The Analytical > Cash Flow report is not
intended to be affected by print levels. However, in 2017 and 2018, when a higher
print level was used with the report, all accounts were still shown but some
amounts were missing. The report was incorrectly trying to honor print settings
higher than 1.

PSPA Version 2018.492
The following enhancements and resolved issues were included in the 2018.492
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● Fair Value Calculation and Discount Spread - In prior versions of 2018, if setup was

changed (in Chart of Accounts > Matr/Repr tab > Fair Value Options) so that the
Discount Spread was affected, calculating Fair Value did not update the Discount
Spread value.
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Before this fix, users had to go to Tools > Maintenance > Calculate Discount
Spread to accomplish this.

● Last FV Calc Date in Report Wizard - Previously in 2018, when the Fair Value Matrix
report was selected in the Report Wizard, the Last FV Calc date shown on the
Selection tab was incorrect. This date did not affect the data in the reports.

● Long Titles in Setup Reports - If a user requested long account titles for any
Documentation > Setup report that showed titles, the program still showed short
titles. The one exception was the Balance Sheet Setup report.

● Order of Selected Projections in a UDQP Group - When User-Defined Quick
Projections were combined into a Projections Group, they did not always stay in
the desired order if that order was not alphabetical or numerical.

● UDQP Duplicate Key Error - Following a 2012–2018 data conversion, some data
sets returned an error if users changed and then attempted to save an existing
User-Defined Quick Projection.

● Data Has Changed Message in Allocations - When a Range of Months option was
used to run Allocations, the label in Allocations and on the reports was incorrectly
saying that data had changed since the last time Allocations were run. This was
not a data issue.

PSPA Version 2018.477
The following enhancements and resolved issues were included in the 2018.477
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● User-Defined Quick Projections Groups - In prior versions of 2018, it was not

possible to create User-Defined Quick Projection groups.
● Fair Value - Book Value Results - In 2018, when the Book Value scenario was

selected but the Projections scenario was not, Book Value results in the matrix
were all zero.

● Report Writer Performance - Reports using formulas to retrieve data were
experiencing poor performance.

● Report Writer Margins - The four margin controls, found at Report Writer > File >
Page Setup > Page tab, were blank and could not be edited in earlier versions of
2018.

● Allocation Date - PROFITability's allocation date was not correct when the client
and service were on machines in different time zones.
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PSPA Version 2018.446
The following enhancements and resolved issues were included in the 2018.446
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Report Wizard - Selecting FV - Int Rate Risk Exposure Scenarios (PS Only)
When requesting the FV - Int Rate Risk Exposure report, the Selection tab now lets you
choose the scenarios to include in the report.

Fixes
● Fair Value - The Fair Value discount factor for non-rate bearing accounts was not

correct in annual time frames.
● Fair Value - When Portfolio data existed in a model, it was always used for Fair

Value calculations, even when the Use Portfolio Detail option was turned off on
the Setup > Preferences > Model Setup tab. For example, Shocked Quote values
were not used if Portfolio detail had been used in the past.

● IRSA - The values on the IRSA Income Statement report were incorrect if the
selected rate scenarios were changed on the Report Wizard Selection tab.

● Report Writer – An enhancement fix caused the performance of Report Writer
reports to be slower in 2018 than it was in 2017.

● Variance Reports - The Variance Reports list box on the Data tab of the Report
Wizard did not show all the reports if there were more than would fit in the box. (Go
to Reports > Report Wizard > Variance to find the Variance Reports list box.)
Now, a vertical scroll bar appears when it is needed so you can see all the reports.

PSPA Version 2018.424
The following enhancements and resolved issues were included in the 2018.424
release of the PROFITstar (PS) and PROFITability (PA) programs.

Fixes
● Fair Value Book Value Row - In previous 2018 versions, you could move the Book

Value scenario from the Selected Rate Scenarios column to the Available Rate
Scenarios column in the Manage Scenarios dialog box so that the scenario does
not appear in the Fair Value matrix. However, when the Book Value scenario was
returned to the Selected Rate Scenarios column it did not stay there, and Book
Value was not included in the Fair Value results.
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● IRSA Income Data - The IRSA Income data item (Data item 80) was returning zero
when it was referenced in Report Writer reports or user-defined graphs.

PSPA Version 2018.421
The following enhancements and resolved issues were included in the 2018.421
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

Risk Analysis - Save IRSA Scenarios as Models (PS Only)
In place of the pre-2018 Copy to Projections functionality, you can now calculate the
IRSA matrix, right-click a row in the grid, and save a scenario as a new model.
To perform this action, select Save Scenario as a Model from the right-click menu to
open the Save dialog box.
Supply a model name and select OK to create a model from the active model's data,
which has a projection based on the IRSA results from the selected scenario. When
the new model is created, only data for the current organization is copied.

Report Wizard - Product Profit Reports (PA Only)
Two changes have been made to the Product Profit reports, which were introduced in
2018.418:
● Amounts that come from accounts without assigned special codes are now

placed in an Uncoded Expense line, immediately preceding Net Income.
Previously, these amounts went to either Uncategorized Income or Uncategorized
Expense lines on the reports.

● The Product Profit Per Account report now shows the product cost figures in
dollars and cents so that the smaller values are meaningful. In addition, only the
Average Balance and Number of Accounts values on the report can be formatted
to display as either Whole Dollars or Thousands.

Fixes
● Email Validation Resend Button - In 2018.418, if a user selected the Resend button

in the Email Validation dialog box, the program failed to send another validation
code to the user's email account.

● Save as Custom Report - On rare occasions, when saving a Report Wizard report
as a custom report, the save dialog would assign an existing custom report name
to the new custom report. Then, if the user happened to cancel the process, the
pre-existing report was deleted. This issue could only happen to Suite clients.
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PSPA Version 2018.418
The following enhancements and resolved issues were included in the 2018.418
release of the PROFITstar (PS) and PROFITability (PA) programs.

Enhancements

CECL - Integrating CECL Loan Loss Rates into Projections
Financial institutions that are licensed for the CECL Analysis and Reporting solution,
in the Financial Performance Suite (FPS), can now download their loan loss rates into
PROFITstar. This option makes it possible for you to integrate CECL loss rates into your
PROFITstar projections where your allowance for loan and lease loss balances are
automatically calculated.
To accomplish this action, new menu commands, settings, and reports have been
added:
● Tools > CECL Integration > Setup is used for a one-time FPS Integration sign-in.
● Tools > CECL Integration > Download is used to bring CECL loan categories and

the loan loss rates into PROFITstar. (This setup can also be done as a step in the
Update Wizard.)

● Setup > Chart of Accounts > Advanced tab > CECL is used to pair CECL loan
categories with balance sheet loan accounts.

● Two new CECL options are now available in Setup > Preferences > Model Setup
tab > Auto Allowance for Loan Loss.

● Three new CECL reports can be found at Report Wizard > Documentation
Reports > CECL.

Risk Analysis - IRSA and Fair Value Redesigned and Improved (PS Only)
The appearance and functionality of IRSA and Fair Value has been redesigned and
improved for the 2018 release.
Powerful enhancements now give you the ability to:
● Create Shock interest rate scenarios in Manage Scenarios. When Shock rate

scenarios are used, accounts that are not using key rate ties, limits, and formulas
are shocked in parallel.

● Create Custom forecasts of all key rates and offering rates, which are saved both
as IRSA/FV scenarios and as quick projections.

● Reapply the scenarios month after month since the settings and projected key
rates and offering rates persist.

● Include as many scenarios in each IRSA or Fair Value simulation run as you need.
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● Shock or stress test your assumptions by applying whole-model changes to
decay and prepayment speeds as well as key rate tie betas and key rate tie lags.
These options are set in Calculation Options.

● Select specific scenarios to include in several Risk Analysis reports using the new
Rate Scenarios setting on the Report Wizard's Selection tab.

The scenarios that initially appear are the system-generated scenarios (Projection,
Flat Rates, and Book Value for Fair Value) and those scenarios that were created
from your previous scenarios during the conversion process.

Risk Analysis - IRSA and Fair Value Changes (PS Only)
The last calculation results for IRSA and Fair Value are not converted. These
calculations must be run again in 2018 before results are available.
Other important IRSA and Fair Value changes to be aware of are listed. Items marked
as "Pre-2018" have been replaced with different functionality in the current version:
● Shock Scenarios - Rate scenarios were converted to shock scenarios that produce

the same results.
Previous scenario names are converted to names that describe the
characteristics of the shock. For example, in a pre-2018 version, if Scenario E was
set to drop 50 basis points, over two months, with the rate shock delay set to three
months, then the converted name is: Down 50 bp Shock over 2 mo in 3 mo.

● Copy to Projections (Pre-2018) - While this button no longer appears in the IRSA
matrix, in 2018 you can right-click a row in the grid and choose to Save Scenario
as a Model. This action creates a model with a projection based on the selected
scenario.

● Another way to bring an IRSA scenario into Projections is to create a custom
scenario and then run it as a User-Defined distribution action in Projections.

● Include/Exclude Check Boxes (Pre-2018) - These check boxes are not needed
since you can choose which scenarios to use in Manage Scenarios.

● Model - IRSA and Fair Value are now always calculated for the current model.
● Strategies Button (Pre-2018) - Saved projection strategies are not used in IRSA or

Fair Value since you can now achieve the same thing with Custom Rate Scenarios
(including shocking Yield Curve Twists).

● Rate Shift Method (Pre-2018) - Shock scenarios always apply parallel rate shifts
now. Create custom scenarios if you must apply specific shocks to individual
rates.

● Reordering the Matrix (Pre-2018) - The old functionality is not needed since you
can now arrange the rows in any order you want in Manage Scenarios.
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● Report Writer Reports and User-Defined Graphs - References to IRSA and Fair
Value results must be updated since scenario names have changed, and IRSA
and Fair Value scenarios may be different.

● Select Scenarios (Pre-2018) - Since you can now include an unlimited number of
IRSA and Fair Value scenarios in your calculation, this functionality is not needed.
NOTE
After reviewing these changes, if you prefer to use the pre-2018 interface for IRSA
and Fair Value, you can do so by selecting Use Legacy Risk Analysis, on the
General Settings tab of Preferences Setup.

Monthly Update - Copying History and Maturity/Repricing to Other Models
In the 2018 version, you can now do your monthly update once and then copy
your updated History and Maturity/Repricing data to other What If models. The
prerequisites are that all the models involved are linked models and that the current
months of the models are compatible.
To accomplish this action, switch to a linked model that you want to copy data into.
Then, go to File > Copy > History and choose the source model from the list of linked
models.
This action does not affect any model settings or the Budget module. In addition,
in Projections, your base projection with its assumptions are still intact although the
current month values change.

SQL Support - Running the 2012 Data Conversion After Installing SQL Express
If you run the Data Conversion utility at the end of the server installation and you
installed SQL Express, the SQL Server Computer Name (loacalhost\ProfitstarSQL),
and the SQL Server Database Name (ProfitstarData) is automatically filled in for you.

SQL Support - New Database Functions Tool Added to the File Menu
The File menu's new Database Functions option replaces the previous Backup
Database command.
If you are running SQL Express, in addition to being able to back up your database,
you can restore and delete backups if you have permission to Restore/Manage
Backups. This setting is found in the DB Backup Settings area of the User Permissions
Settings tab.
Users running other versions of SQL can use Database Functions to back up
their SQL database. If any of these users must have access to the restore and
backup functionality found in Database Functions, a configuration file modification
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is required, in addition to the activation of the Restore/Manage Backups user
permission. Contact your Client Support analyst for assistance.

Passwords and User Permissions - Password Handling Is More Robust and Secure
Security administrators now have comprehensive control over how passwords are
handled in the program. The password Security Options, introduced in the 2018
version, include the following features:
● Retry login lockout count
● Password reuse limit count
● Password expires in days
● Temp Password expires in days
● Account idle lockout in days *
● Password minimum length
● Authorized email domains
● Password complexity enabled
Following the 2018 installation, it is important for an administrator to check the
Account Idle Lockout in Days setting and change it, if necessary, to a value that
is appropriate for their users.
Other changes to password functionality include:
● User names can no longer be used as passwords.
● Temporary passwords are generated by the program and are automatically

emailed to users so that administrators no longer see anyone's passwords.
● Users can now change their own passwords by prompting the system to email

them a temporary password from either the Setup > Change Password or the
Login Screen > Forgot Password option.

● The date of the last password change appears on each module's secondary
toolbar.

● A User Security Settings report has been added, which is available from the User
Management tab.

Passwords and User Permissions - Each User Must Be Associated with an Email
Address
To support the improved security features available in the 2018 version of the
program, an email address must now be associated with every user. This
requirement makes it possible for password and email address-related user
notifications to be automatically emailed, either through a secure, cloud-based
server or by way of the local email system. Go to Setup > Preferences > General
Settings > Email to change the preferred email setting.
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Passwords and User Permissions - Initial Email Setup
The first time that existing users log into PROFITstar 2018, they are asked to provide an
email address. Follow these steps to complete this process:
1. Enter your email address in the box provided.
2. When you perform this action, a validation code is sent to your email address.
3. If your session in PROFITstar is still active, a Validate Email dialog box immediately

appears. Copy and paste the validation code and then select Validate.
The Email Validated message appears in the box if the code entered is valid.
Select Resend if a new validation code is needed.

4. If the dialog box is closed without completing the validation process, a Validate
Email command is added to the Setup menu. In addition, whenever the program
is closed and reopened, the Validate Email dialog box remains presented until the
email is validated.

Passwords and User Permissions - Changing Your Email Address
After an email address is associated with your user name, you can change it by
navigating to Setup > Change Email.
Security administrators can also change email addresses on the User Management
screen.

Passwords and User Permissions - New Icon Shows Who Is in the Model
When you first enter the base model or switch to another model, a silhouette icon
appears in the upper right corner of the main screen to let you know if other users
are also in the model. Hover over the icon to see the names of the users. No icon is
shown if you are the only user in the model.
The program's previous locking behaviors have not changed, but to avoid locking
warnings, it can be helpful to know in advance if other users are in the same model.

Report Writer - Reports Load More Quickly
In the 2018 release, the visible portion of a Report Writer report that you are opening
appears quickly, while the rest of the report loads behind the scenes.
Since the reports now load faster, you may occasionally see some cells filled with
question marks while the values are being calculated. These cells are non-editable
until the values are filled in.
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Report Writer - Reports Can Now Be Exported to and Imported from Excel®

Functionality has been added to Report Writer that makes it possible for users to
export their reports to Excel®, and then after customizing the appearance of the
reports, to import the Excel® formatting back to Report Writer.
Use the Report Writer File > Export command to export reports as either .xlsx or .xls
files. When this export is done, only data is exported, not formulas. In addition,
embedded graphs are exported as images.
Use the Report Writer File > Export command to bring the reports' new formatting
back into Report Writer. In the Open Report dialog box, select the Excel Formatting
(*.xlsx) option.
After this process, you can run the reports in Report Writer, without losing the Excel®
formatting.

Report Wizard - Report Wizard Reports Can Be Saved as Excel® Files
Excel® is now an output format option for Report Wizard reports in the Save As box on
the Summary tab.

Report Wizard - Clearing Unit Distribution Report Can Include All Accounts
Previously, the Documentation > Setup > Clearing Unit Distribution report did not
show accounts with a distribution action of None.
Now, the new Include Accounts with No Distributions option found on the Report
Wizard's Format tab makes it possible to display all Balance Sheet, Income
Statement, and Rate accounts on the report.

Report Wizard - New Product PA Reports and Special Account Codes (PA Only)
To provide more meaningful product reporting, three new reports have been added
to the Allocations report type:
● Product Trend - Provides high-level income/expense, balance, and statistical data

trend analysis, by product.
● Product Profit Summary – Provides a product profitability income statement that is

summarized by product-specific special account codes.
● Product Profit Per Account - Provides the same information as the Product Profit

Summary report on a per account basis.
These reports use the new PA special account codes. Before you can obtain useful
information from these reports, it is necessary to assign PA special account codes to
the non-interest income and expense accounts in the Chart of Accounts. This action
is done on the Inc Stmt tab.
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Except for the Net FTP code, all other PA special account codes can be used more
than once. When the new reports are generated, the lines on the reports correspond
to categories of income or expenses, grouped using the special codes. Amounts that
come from accounts without assigned special codes are now placed in an Uncoded
Expense line, immediately preceding Net Income, on the Product Profit reports.

NOTE
These reports are only valid when Product Allocations have been performed.

PROFITability Product Surveys - Product Surveys (PA Only)
PROFITability now gives clients running the Product dimension a platform for
initiating, managing, and reviewing surveys that gather statistics about the average
amount of time spent on various product-related job activities. These metrics are
then used by ProfitStars to create rules for product allocations.
The PROFITability Surveys workflow:
1. The parameters of a survey are defined on the Set Up Survey screen, including

how long the survey accepts responses, who receives emailed links to the survey,
and how the results are organized and weighted.

2. The email message text is customized on the Email Templates tab of the Set Up
Survey screen, if necessary.

3. The survey is started or scheduled for later.
4. Survey takers follow an emailed link to a standard set of survey questions,

maintained by ProfitStars and hosted on a secure website.
5. The survey's completion progress is monitored, and specific results are viewed as

surveys are returned.
6. Follow up emails are sent, if necessary, to survey takers who have not responded.
7. If needed, the email text can be changed or more survey takers can be added,

and the entire survey (or parts of it) can be scheduled to run again.
8. When the survey end date is reached, the survey is closed.
9. Survey results are viewed and exported to an Excel® workbook.

10. An email is sent from within the program to schedule a consultation with a
PROFITability analyst to plan how the survey results are used to create allocation
rules.

Usage Statistics - More Activities Included / Submitted as a Scheduled Activity
With the permission of an administrator-level user (granted when the usage
statistics confirmation message is accepted), the program gathers information
related to how it is used, configured, and how it performs. The insights obtained from
these statistics help in the prioritization of new features.
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In the 2018 edition, the information gathered and the process for submitting it to
ProfitStars has changed:
● New statistical information gathered:

○ Report Writer Open
○ Report Writer Print
○ Report Wizard Run
○ IRSA Open
○ IRSA Calculate
○ Fair Value Open
○ Fair Value Calculate
○ Maturity Repricing Open
○ Client Computer
○ Server Computer
○ SQL Server® Computer

● Now there are two ways to submit the usage statistics:
○ Go to Tools > Maintenance > Usage Statistics > Send to submit manually the

collected stats.
○ Go to Tools > Maintenance > Usage Statistics > Enable Scheduler to cause the

stats to be submitted automatically once a week as a scheduled activity. To
turn off this option, browse to this location again and select Disable Scheduler.

Important 2018 Edition Information
Important information regarding the PROFITstar (PS) and PROFITability (PA) 2018
edition is listed here.

Software Version Change
To be consistent with our corporate software version standards, PS and PA no
longer use letters to identify periodic minor versions. Now, our software releases
show an annual version followed by an incremented build number. When a new
version is announced, refer to the Release Notes to see if your institution needs the
enhancements and fixes it contains.

User Account Lockouts
In the 2018 version, security administrators now have comprehensive control over
how passwords are handled in the program. As part of this enhanced functionality,
users are locked out of the program if they have not logged in for some number of
days. The Account Idle Lockout in Days setting on the Security Options tab of the
User Setup screen controls this behavior.
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Following the 2018 installation, it is important for an administrator to go to Setup >
User Permissions > Security Options. The administrator must check that Account
Idle Lockout in Days is set to a value that is appropriate for the institution's users.

Known Issues
● Avoid using the Arial Unicode MS font for PDF reports.

If you have the Arial Unicode MS font installed and you use it to generate a Report
Writer report as a PDF file, then the output appears corrupt and PS closes with no
error. There are no errors when such a report is previewed or printed.
The same behavior is seen if you select this font when setting up Variance Report
columns and then you send the Variance Report to a PDF file.
Do not use the Arial Unicode MS font for Report Writer or Variance PDF reports.

● Error occurs for the rate scenarios selection in the Report Wizard screen.
After moving to the 2018 version, some clients have received an error when
attempting to preview or save an IRSA or Fair Value Documentation report.
If this error occurs, then return to the Selection tab on the Report Wizard screen
and choose a different scenario from the Rate Scenarios list. Previewing or saving
the report for a different scenario corrects the problem.
When you reselect the first scenario and generate the report, the error does not
occur again.

Technical Change - SQL Express Support
PROFITstar Server installation can now install SQL Express.
During the PROFITstar Server installation, the program determines if an instance of
SQL Server® is already installed on the targeted server. If not, then the installer adds a
few steps.
First, select the statements that are true for your institution. If you select both
statements, then additional information is shown.
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Select the Install SQL Express check box if you want to proceed. When you select
Next, the SQL Express installation runs without any required intervention.
The SQL Express 2016 installer installs a database engine that supports up to 10 GB
per database.

TIP
If your institution is using SQL Express, then you must
also download and install SQL Server® Management Studio
(SSMS) from: https://docs.microsoft.com/en-us/sql/ssms/download-sql-server-
management-studio-ssms?view=sql-server-2017. SSMS is a separate and free
software installation. SSMS 17.x works with any older versions of SQL Server® and is
useful for problem solving and other purposes.
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